pakage/rpi-userland: add and install our bcm_host.pc
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 5 Oct 2013 22:17:17 +0000 (00:17 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 6 Oct 2013 18:47:22 +0000 (20:47 +0200)
This allows pkg-config-aware packages to include headers from, and
link against Broadcom VideoCore host API library.

bcm_host.pc copied almost as-is from:
    http://cgit.collabora.com/git/user/pq/android-pc-files.git/tree/pkgconfig?h=raspberrypi
with only a fix to the prefix (we're using /usr).

[Peter: s/TARGET/STAGING/]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rpi-userland/bcm_host.pc [new file with mode: 0644]
package/rpi-userland/rpi-userland.mk

diff --git a/package/rpi-userland/bcm_host.pc b/package/rpi-userland/bcm_host.pc
new file mode 100644 (file)
index 0000000..28bbe96
--- /dev/null
@@ -0,0 +1,11 @@
+prefix=/usr
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+includedir=${prefix}/include
+
+Name: bcm_host
+Description: Broadcom VideoCore host API library
+Version: 1
+Libs: -L${libdir} -lbcm_host -lvcos -lvchiq_arm
+Cflags: -I${includedir} -I${includedir}/interface/vmcs_host/linux -I${includedir}/interface/vcos/pthreads -DUSE_VCHIQ_ARM
+
index c3ea43a9f4d2eca23d1430175bd9083d6654ecc9..cc032bfcd9d900234c46a3c5d5eb01bc53c71e60 100644 (file)
@@ -14,7 +14,12 @@ RPI_USERLAND_CONF_OPT = -DVMCS_INSTALL_PREFIX=/usr
 define RPI_USERLAND_POST_TARGET_CLEANUP
     rm -Rf $(TARGET_DIR)/usr/src
 endef
-
 RPI_USERLAND_POST_INSTALL_TARGET_HOOKS += RPI_USERLAND_POST_TARGET_CLEANUP
 
+define RPI_USERLAND_POST_STAGING_PC_FILE
+       install -D -m 0644 package/rpi-userland/bcm_host.pc \
+               $(STAGING_DIR)/usr/lib/pkgconfig/bcm_host.pc
+endef
+RPI_USERLAND_POST_INSTALL_STAGING_HOOKS += RPI_USERLAND_POST_STAGING_PC_FILE
+
 $(eval $(cmake-package))