squeezelite: reformat existing patch as a Git formatted patch
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Feb 2016 17:17:13 +0000 (18:17 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Feb 2016 17:17:13 +0000 (18:17 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/squeezelite/0001-Makefile-allow-passing-CFLAGS-and-LDFLAGS.patch [new file with mode: 0644]
package/squeezelite/0001-Makefile-override.patch [deleted file]

diff --git a/package/squeezelite/0001-Makefile-allow-passing-CFLAGS-and-LDFLAGS.patch b/package/squeezelite/0001-Makefile-allow-passing-CFLAGS-and-LDFLAGS.patch
new file mode 100644 (file)
index 0000000..2f002a8
--- /dev/null
@@ -0,0 +1,54 @@
+From a0f2e79d1373967dac9f3df4c500a71cd1b96b2b Mon Sep 17 00:00:00 2001
+From: Hiroshi Kawashima <kei-k@ca2.so-net.ne.jp>
+Date: Sun, 7 Feb 2016 18:04:53 +0100
+Subject: [PATCH] Makefile: allow passing CFLAGS and LDFLAGS
+
+This patch is applied to squeezelite Makefile to add override
+directive for CFLAGS and LDFLAGS assignment.
+This enables adding flags to CFLAGS and LDFLAGS in Makefile.
+
+Signed-off-by: Hiroshi Kawashima <kei-k@ca2.so-net.ne.jp>
+---
+ Makefile | 12 +++++++-----
+ 1 file changed, 7 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index dca2abd..286c725 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,6 @@
+ # Cross compile support - create a Makefile which defines these three variables and then includes this Makefile...
++override CFLAGS += $(OPTS)
++override LDFLAGS += -lasound -lpthread -lm -lrt
+ CFLAGS  ?= -Wall -fPIC -O2 $(OPTS)
+ LDFLAGS ?= -lasound -lpthread -lm -lrt
+ EXECUTABLE ?= squeezelite
+@@ -52,20 +54,20 @@ endif
+ # add optional link options
+ ifneq (,$(findstring $(OPT_LINKALL), $(CFLAGS)))
+-      LDFLAGS += $(LINKALL)
++      override LDFLAGS += $(LINKALL)
+ ifneq (,$(findstring $(OPT_FF), $(CFLAGS)))
+-      LDFLAGS += $(LINKALL_FF)
++      override LDFLAGS += $(LINKALL_FF)
+ endif
+ ifneq (,$(findstring $(OPT_RESAMPLE), $(CFLAGS)))
+-      LDFLAGS += $(LINKALL_RESAMPLE)
++      override LDFLAGS += $(LINKALL_RESAMPLE)
+ endif
+ ifneq (,$(findstring $(OPT_IR), $(CFLAGS)))
+-      LDFLAGS += $(LINKALL_IR)
++      override LDFLAGS += $(LINKALL_IR)
+ endif
+ else
+ # if not LINKALL and linux add LINK_LINUX
+ ifeq ($(UNAME), Linux)
+-      LDFLAGS += $(LINK_LINUX)
++      override LDFLAGS += $(LINK_LINUX)
+ endif
+ endif
+-- 
+2.6.4
+
diff --git a/package/squeezelite/0001-Makefile-override.patch b/package/squeezelite/0001-Makefile-override.patch
deleted file mode 100644 (file)
index 4e11541..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-This patch is applied to squeezelite Makefile to add override
-directive for CFLAGS and LDFLAGS assignment.
-This enables adding flags to CFLAGS and LDFLAGS in Makefile.
-
-Signed-off-by: Hiroshi Kawashima <kei-k@ca2.so-net.ne.jp>
-
-diff -ruN a/Makefile b/Makefile
---- a/Makefile 2015-02-01 23:56:21.000000000 +0900
-+++ b/Makefile 2015-09-29 20:06:52.268069187 +0900
-@@ -1,4 +1,6 @@
- # Cross compile support - create a Makefile which defines these three variables and then includes this Makefile...
-+override CFLAGS += $(OPTS)
-+override LDFLAGS += -lasound -lpthread -lm -lrt
- CFLAGS  ?= -Wall -fPIC -O2 $(OPTS)
- LDFLAGS ?= -lasound -lpthread -lm -lrt
- EXECUTABLE ?= squeezelite
-@@ -52,20 +54,20 @@
- # add optional link options
- ifneq (,$(findstring $(OPT_LINKALL), $(CFLAGS)))
--      LDFLAGS += $(LINKALL)
-+      override LDFLAGS += $(LINKALL)
- ifneq (,$(findstring $(OPT_FF), $(CFLAGS)))
--      LDFLAGS += $(LINKALL_FF)
-+      override LDFLAGS += $(LINKALL_FF)
- endif
- ifneq (,$(findstring $(OPT_RESAMPLE), $(CFLAGS)))
--      LDFLAGS += $(LINKALL_RESAMPLE)
-+      override LDFLAGS += $(LINKALL_RESAMPLE)
- endif
- ifneq (,$(findstring $(OPT_IR), $(CFLAGS)))
--      LDFLAGS += $(LINKALL_IR)
-+      override LDFLAGS += $(LINKALL_IR)
- endif
- else
- # if not LINKALL and linux add LINK_LINUX
- ifeq ($(UNAME), Linux)
--      LDFLAGS += $(LINK_LINUX)
-+      override LDFLAGS += $(LINK_LINUX)
- endif
- endif