input-event-daemon: install configuration file unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:49 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:27:39 +0000 (00:27 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/input-event-daemon/input-event-daemon.mk

index 0bafdc4e1a7b0db2cd457589f7aacd0407a78cd8..67b8cc4ba6c8cb9f983c3afbdc1b6c8c2f0f1393 100644 (file)
@@ -18,9 +18,8 @@ endef
 define INPUT_EVENT_DAEMON_INSTALL_TARGET_CMDS
        $(INSTALL) -m 755 -D $(@D)/input-event-daemon \
                $(TARGET_DIR)/usr/bin/input-event-daemon
-       [ -f $(TARGET_DIR)/etc/input-event-daemon.conf ] || \
-               $(INSTALL) -m 644 -D $(@D)/docs/sample.conf \
-                       $(TARGET_DIR)/etc/input-event-daemon.conf
+       $(INSTALL) -m 644 -D $(@D)/docs/sample.conf \
+               $(TARGET_DIR)/etc/input-event-daemon.conf
 endef
 
 define INPUT_EVENT_DAEMON_INSTALL_INIT_SYSV