package/clamav: needs dynamic library
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 23 Sep 2020 17:54:36 +0000 (19:54 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 23 Sep 2020 18:45:23 +0000 (20:45 +0200)
Upstream commit
https://github.com/Cisco-Talos/clamav-devel/commit/9e20cdf6eaf545a66f55ce5ba85ef9a98dad3648
added dlopen() to others.c
https://github.com/Cisco-Talos/clamav-devel/blob/dev/0.104/libclamav/others.c#L199

"libclamav used to build in multiple stages where an earlier stage is
a static library containing utils required by the "shared" code.
Linking clamdscan and clamdtop with this libclamav utils static lib
allowed these two apps to function without libclamav. While this is
nice in theory, the practical gains are minimal and it complicates
the build system. As such, the autotools and CMake tooling was
simplified for improved maintainability and this feature was thrown
out. clamdtop and clamdscan now require libclamav to function."

Fixes:
http://autobuild.buildroot.net/results/e27/e276894781e3e37fbc03a0745738c61541e0a211/
http://autobuild.buildroot.net/results/552/552ee8d9e44152c9d7e315a5491542771264d466/
http://autobuild.buildroot.net/results/fde/fde4af47542f0eb0bd57b172c99bd086eb566b76/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/clamav/Config.in
package/clamav/clamav.mk

index 08f3e47461978b2d4a6650acf7028ff0339da7e3..990a818b5c631202a03ba36858a8025c075ba9e8 100644 (file)
@@ -3,10 +3,10 @@ config BR2_PACKAGE_CLAMAV
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_USE_MMU # fork()
+       depends on !BR2_STATIC_LIBS # dlopen
        depends on BR2_USE_WCHAR
        select BR2_PACKAGE_LIBCURL
        select BR2_PACKAGE_LIBMSPACK
-       select BR2_PACKAGE_LIBTOOL
        select BR2_PACKAGE_MUSL_FTS if !BR2_TOOLCHAIN_USES_GLIBC
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_ZLIB
@@ -16,7 +16,7 @@ config BR2_PACKAGE_CLAMAV
 
          http://www.clamav.net
 
-comment "clamav needs a toolchain w/ C++, threads, wchar"
-       depends on !BR2_INSTALL_LIBSTDCPP \
+comment "clamav needs a toolchain w/ C++, dynamic library, threads, wchar"
+       depends on !BR2_INSTALL_LIBSTDCPP || BR2_STATIC_LIBS \
                || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
        depends on BR2_USE_MMU
index fc979a74aa0dcc673873080a06ef7f53bb5bb507..45d62943a069dd1b4f73d630d7c9e9fdc736110a 100644 (file)
@@ -14,7 +14,6 @@ CLAMAV_DEPENDENCIES = \
        host-pkgconf \
        libcurl \
        libmspack \
-       libtool \
        openssl \
        zlib \
        $(TARGET_NLS_DEPENDENCIES)
@@ -38,8 +37,6 @@ CLAMAV_CONF_ENV += LIBS="$(CLAMAV_LIBS)"
 
 CLAMAV_CONF_OPTS = \
        --with-dbdir=/var/lib/clamav \
-       --with-ltdl-include=$(STAGING_DIR)/usr/include \
-       --with-ltdl-lib=$(STAGING_DIR)/usr/lib \
        --with-libcurl=$(STAGING_DIR)/usr \
        --with-openssl=$(STAGING_DIR)/usr \
        --with-system-libmspack=$(STAGING_DIR)/usr \