package/grpc: fix build on ubuntu gcc 4.8
authorMichael Nosthoff <buildroot@heine.tech>
Tue, 15 Sep 2020 16:11:07 +0000 (18:11 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 19 Sep 2020 08:17:33 +0000 (10:17 +0200)
gcc 4.8 on ubuntu 14.04 does some broken optimization at link-time
which causes grpc to create a grpc_cpp_plugin which quits because
of a failing assertion. The created plugin is itself used during
compilation which lets the build fail.
With the added -Wl,--no-as-needed flag the LTO is disabled and grpc
compiles successfully.

fixes:
- http://autobuild.buildroot.net/results/b554f6f2fb66892273f7520ad6e36923557b229e
- http://autobuild.buildroot.net/results/3ebb2880b9b3fd5154979016391dde897e2c039c
- http://autobuild.buildroot.net/results/c2078e821e0728fe980be2c849c25d82e791a4c2

Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
[yann.morin.1998@free.fr: rewrap the comment]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/grpc/grpc.mk

index 2114f98e402654ec3efabf197fb965261fd2e7f5..613f45daccfc24757139fbd3e5684ebf92a4d149 100644 (file)
@@ -72,5 +72,13 @@ HOST_GRPC_CONF_OPTS = \
        -DgRPC_ZLIB_PROVIDER=package \
        -DgRPC_ABSL_PROVIDER=package
 
+# With gcc 4.8 (at least on ubuntu) there is a bug in LTO which breaks
+# the linkage of the grpc_cpp_plugin with libprotobuf and pthread. This
+# additional flag fixes this.
+ifeq ($(BR2_HOST_GCC_AT_LEAST_4_9),)
+HOST_GRPC_CONF_OPTS += \
+       -DCMAKE_EXE_LINKER_FLAGS="$(HOST_LDFLAGS) -Wl,--no-as-needed"
+endif
+
 $(eval $(cmake-package))
 $(eval $(host-cmake-package))