kernel-headers: bump to version 3.0.7 and add version 3.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 24 Oct 2011 14:54:02 +0000 (11:54 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 24 Oct 2011 15:48:28 +0000 (17:48 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/kernel-headers/Config.in
toolchain/kernel-headers/kernel-headers.mk
toolchain/kernel-headers/linux-3.0.4-headers_install-fix-__packed-in-exported-kernel-head.patch [deleted file]
toolchain/kernel-headers/linux-3.0.7-headers_install-fix-__packed-in-exported-kernel-head.patch [new file with mode: 0644]

index b827ec5be0f0a8610bb3ead50a074be5a1d16277..8be9186bebbf1246dd492544fb1824a5bc059990 100644 (file)
@@ -6,7 +6,7 @@ comment "Kernel Header Options"
 
 choice
        prompt "Kernel Headers"
-       default BR2_KERNEL_HEADERS_3_0
+       default BR2_KERNEL_HEADERS_3_1
        help
          Select the version of kernel header files you wish to use.
          You must select the correct set of header files to match
@@ -33,6 +33,9 @@ choice
        config BR2_KERNEL_HEADERS_3_0
                bool "Linux 3.0.x kernel headers"
 
+       config BR2_KERNEL_HEADERS_3_1
+               bool "Linux 3.1.x kernel headers"
+
        config BR2_KERNEL_HEADERS_VERSION
                bool "Linux 2.6 (manually specified version)"
 
@@ -54,6 +57,7 @@ config BR2_DEFAULT_KERNEL_HEADERS
        default "2.6.37.6"      if BR2_KERNEL_HEADERS_2_6_37
        default "2.6.38.8"      if BR2_KERNEL_HEADERS_2_6_38
        default "2.6.39.4"      if BR2_KERNEL_HEADERS_2_6_39
-       default "3.0.4"         if BR2_KERNEL_HEADERS_3_0
+       default "3.0.7"         if BR2_KERNEL_HEADERS_3_0
+       default "3.1"           if BR2_KERNEL_HEADERS_3_1
        default "2.6"           if BR2_KERNEL_HEADERS_SNAP
        default $BR2_DEFAULT_KERNEL_VERSION if BR2_KERNEL_HEADERS_VERSION
index 044fcf9477b349054aaa1a593bae7c40459a58cc..72c600766d5a6f123515a770437068f644621ef8 100644 (file)
@@ -29,7 +29,7 @@ LINUX_HEADERS_VERSION:=$(VERSION).$(PATCHLEVEL)$(SUBLEVEL)$(EXTRAVERSION)
 ifeq ($(findstring x2.6.,x$(DEFAULT_KERNEL_HEADERS)),x2.6.)
 LINUX_HEADERS_SITE:=$(BR2_KERNEL_MIRROR)/linux/kernel/v2.6/
 else
-LINUX_HEADERS_SITE:=$(BR2_KERNEL_MIRROR)/linux/kernel/v3.0/
+LINUX_HEADERS_SITE:=$(BR2_KERNEL_MIRROR)/linux/kernel/v3.x/
 endif
 LINUX_HEADERS_SOURCE:=linux-$(LINUX_HEADERS_VERSION).tar.bz2
 LINUX_HEADERS_CAT:=$(BZCAT)
diff --git a/toolchain/kernel-headers/linux-3.0.4-headers_install-fix-__packed-in-exported-kernel-head.patch b/toolchain/kernel-headers/linux-3.0.4-headers_install-fix-__packed-in-exported-kernel-head.patch
deleted file mode 100644 (file)
index 8777b71..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-From f210735fe2f17a6225432ee3d1239bcf23a8659c Mon Sep 17 00:00:00 2001
-From: Markus Trippelsdorf <markus@trippelsdorf.de>
-Date: Fri, 24 Jun 2011 15:51:00 +0200
-Subject: [PATCH] headers_install: fix __packed in exported kernel headers
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-checkpatch.pl warns about using __attribute__((packed)) in kernel
-headers: "__packed is preferred over __attribute__((packed))". If one
-follows that advice it could cause problems in the exported header
-files, because the outside world doesn't know about this shortcut.
-
-For example busybox will fail to compile:
- CC      miscutils/ubi_attach_detach.o
- In file included from miscutils/ubi_attach_detach.c:27:0:
- /usr/include/mtd/ubi-user.h:330:3: error: conflicting types for ‘__packed’
- /usr/include/mtd/ubi-user.h:314:3: note: previous declaration of ‘__packed’ was here
-...
-
-Fix the problem by substituting __packed with __attribute__((packed)) in
-the header_install.pl script.
-
-Cc: Artem Bityutskiy <Artem.Bityutskiy@nokia.com>
-CC: Joe Perches <joe@perches.com>
-Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
-Signed-off-by: Michal Marek <mmarek@suse.cz>
----
- scripts/headers_install.pl |    1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
-
-diff --git a/scripts/headers_install.pl b/scripts/headers_install.pl
-index efb3be1..48462be 100644
---- a/scripts/headers_install.pl
-+++ b/scripts/headers_install.pl
-@@ -35,6 +35,7 @@ foreach my $file (@files) {
-               $line =~ s/([\s(])__iomem\s/$1/g;
-               $line =~ s/\s__attribute_const__\s/ /g;
-               $line =~ s/\s__attribute_const__$//g;
-+              $line =~ s/\b__packed\b/__attribute__((packed))/g;
-               $line =~ s/^#include <linux\/compiler.h>//;
-               $line =~ s/(^|\s)(inline)\b/$1__$2__/g;
-               $line =~ s/(^|\s)(asm)\b(\s|[(]|$)/$1__$2__$3/g;
--- 
-1.7.5.4
-
diff --git a/toolchain/kernel-headers/linux-3.0.7-headers_install-fix-__packed-in-exported-kernel-head.patch b/toolchain/kernel-headers/linux-3.0.7-headers_install-fix-__packed-in-exported-kernel-head.patch
new file mode 100644 (file)
index 0000000..8777b71
--- /dev/null
@@ -0,0 +1,46 @@
+From f210735fe2f17a6225432ee3d1239bcf23a8659c Mon Sep 17 00:00:00 2001
+From: Markus Trippelsdorf <markus@trippelsdorf.de>
+Date: Fri, 24 Jun 2011 15:51:00 +0200
+Subject: [PATCH] headers_install: fix __packed in exported kernel headers
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+checkpatch.pl warns about using __attribute__((packed)) in kernel
+headers: "__packed is preferred over __attribute__((packed))". If one
+follows that advice it could cause problems in the exported header
+files, because the outside world doesn't know about this shortcut.
+
+For example busybox will fail to compile:
+ CC      miscutils/ubi_attach_detach.o
+ In file included from miscutils/ubi_attach_detach.c:27:0:
+ /usr/include/mtd/ubi-user.h:330:3: error: conflicting types for ‘__packed’
+ /usr/include/mtd/ubi-user.h:314:3: note: previous declaration of ‘__packed’ was here
+...
+
+Fix the problem by substituting __packed with __attribute__((packed)) in
+the header_install.pl script.
+
+Cc: Artem Bityutskiy <Artem.Bityutskiy@nokia.com>
+CC: Joe Perches <joe@perches.com>
+Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
+Signed-off-by: Michal Marek <mmarek@suse.cz>
+---
+ scripts/headers_install.pl |    1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/scripts/headers_install.pl b/scripts/headers_install.pl
+index efb3be1..48462be 100644
+--- a/scripts/headers_install.pl
++++ b/scripts/headers_install.pl
+@@ -35,6 +35,7 @@ foreach my $file (@files) {
+               $line =~ s/([\s(])__iomem\s/$1/g;
+               $line =~ s/\s__attribute_const__\s/ /g;
+               $line =~ s/\s__attribute_const__$//g;
++              $line =~ s/\b__packed\b/__attribute__((packed))/g;
+               $line =~ s/^#include <linux\/compiler.h>//;
+               $line =~ s/(^|\s)(inline)\b/$1__$2__/g;
+               $line =~ s/(^|\s)(asm)\b(\s|[(]|$)/$1__$2__$3/g;
+-- 
+1.7.5.4
+