package/libgit2: bump version to 0.28.3
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>
Mon, 19 Aug 2019 09:43:46 +0000 (11:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Aug 2019 13:37:57 +0000 (15:37 +0200)
Remove the cURL dependency, since they reimplemented a HTTP client.

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libgit2/libgit2.hash
package/libgit2/libgit2.mk

index 54e309172a8de34f6c41d3a8c0c6605af1c34297..f445e4cf0fa1f0cd9ad7b81e55d9365df35b8661 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 8313873d49dc01e8b880ec334d7430ae67496a89aaa8c6e7bbd3affb47a00c76  libgit2-0.27.8.tar.gz
+sha256 ee5344730fe11ce7c86646e19c2d257757be293f5a567548d398fb3af8b8e53b  libgit2-0.28.3.tar.gz
 sha256 d9a8038088df84fde493fa33a0f1e537252eeb9642122aa4b862690197152813  COPYING
index b8880fea812f3421623619d32b96c0559e06d1ff..e4d887d9b2d1c7f4f5a4fe08beeca447ab270a1a 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBGIT2_VERSION = 0.27.8
+LIBGIT2_VERSION = 0.28.3
 LIBGIT2_SITE = $(call github,libgit2,libgit2,v$(LIBGIT2_VERSION))
 LIBGIT2_LICENSE = GPL-2.0 with linking exception
 LIBGIT2_LICENSE_FILES = COPYING
@@ -41,11 +41,4 @@ else
 LIBGIT2_CONF_OPTS += -DUSE_HTTPS=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_LIBCURL),y)
-LIBGIT2_DEPENDENCIES += libcurl
-LIBGIT2_CONF_OPTS += -DCURL=ON
-else
-LIBGIT2_CONF_OPTS += -DCURL=OFF
-endif
-
 $(eval $(cmake-package))