package/python-pyqt5: QtSvg needs QtWidgets
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 17 May 2020 12:27:38 +0000 (14:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 17 Oct 2020 13:01:40 +0000 (15:01 +0200)
Building QtSvg without QtWidgets results in the following build failure:

/tmp/instance-0/output-1/host/bin/powerpc64le-linux-g++ -c -pipe -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Os --sysroot=/tmp/instance-0/output-1/host/powerpc64le-buildroot-linux-gnu/sysroot -fno-exceptions -Wall -Wextra -D_REENTRANT -fPIC -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DQT_NO_DEBUG -DQT_PLUGIN -DQT_SVG_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -I. -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/python3.8 -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5 -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5/QtSvg -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5/QtGui -I../../../host/powerpc64le-buildroot-linux-gnu/sysroot/usr/include/qt5/QtCore -I. -I../../../host/mkspecs/devices/linux-buildroot-g++ -o sipQtSvgcmodule.o sipQtSvgcmodule.cpp
sip/QtWidgets/qwidget.sip:28:10: fatal error: qwidget.h: No such file or directory
compilation terminated.
sip/QtWidgets/qgraphicsitem.sip:26:10: fatal error: qgraphicsitem.h: No such file or directory
compilation terminated.

Fixes:
 - http://autobuild.buildroot.org/results/26f55a1fa9f6520ce449b98b40d98f984cec07b3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-pyqt5/python-pyqt5.mk

index 9b5e9089fc99d5ed67cee346f51f80d394271136..9285b6497c6793d81cbdadb8e31b9122b3c0d415 100644 (file)
@@ -39,6 +39,12 @@ endif
 ifeq ($(BR2_PACKAGE_QT5BASE_TEST),y)
 PYTHON_PYQT5_MODULES += QtTest
 endif
+
+# QtSvg needs QtWidgets
+ifeq ($(BR2_PACKAGE_QT5SVG),y)
+PYTHON_PYQT5_DEPENDENCIES += qt5svg
+PYTHON_PYQT5_MODULES += QtSvg
+endif
 endif
 
 ifeq ($(BR2_PACKAGE_QT5CONNECTIVITY),y)
@@ -88,11 +94,6 @@ PYTHON_PYQT5_DEPENDENCIES += qt5serialport
 PYTHON_PYQT5_MODULES += QtSerialPort
 endif
 
-ifeq ($(BR2_PACKAGE_QT5SVG),y)
-PYTHON_PYQT5_DEPENDENCIES += qt5svg
-PYTHON_PYQT5_MODULES += QtSvg
-endif
-
 ifeq ($(BR2_PACKAGE_QT5WEBCHANNEL),y)
 PYTHON_PYQT5_DEPENDENCIES += qt5webchannel
 PYTHON_PYQT5_MODULES += QtWebChannel