package/lua-codegen: new package
authorFrancois Perrad <fperrad@gmail.com>
Thu, 5 Sep 2019 08:08:39 +0000 (10:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 6 Jan 2020 20:49:58 +0000 (21:49 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Reviewed-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/lua-codegen/Config.in [new file with mode: 0644]
package/lua-codegen/lua-codegen.hash [new file with mode: 0644]
package/lua-codegen/lua-codegen.mk [new file with mode: 0644]

index 296dbe49d5a2822aff5566b249d69ef41398133c..3a755611518928719d5d330384dcddd7f0ae3d0d 100644 (file)
@@ -636,6 +636,7 @@ menu "Lua libraries/modules"
        source "package/lua-cjson/Config.in"
        source "package/lua-coat/Config.in"
        source "package/lua-coatpersistent/Config.in"
+       source "package/lua-codegen/Config.in"
        source "package/lua-compat53/Config.in"
        source "package/lua-cqueues/Config.in"
        source "package/lua-csnappy/Config.in"
diff --git a/package/lua-codegen/Config.in b/package/lua-codegen/Config.in
new file mode 100644 (file)
index 0000000..fbcf5ca
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LUA_CODEGEN
+       bool "lua-codegen"
+       help
+         A template engine.
+
+         https://fperrad.frama.io/lua-CodeGen
diff --git a/package/lua-codegen/lua-codegen.hash b/package/lua-codegen/lua-codegen.hash
new file mode 100644 (file)
index 0000000..0b49a5a
--- /dev/null
@@ -0,0 +1,3 @@
+# computed by luarocks/buildroot
+sha256 c09126d7f5d0fa9c867ee9108eb5961dab111320ee35e5f842317f6058e922ec  lua-codegen-0.3.3-1.src.rock
+sha256 f09265c450c3a59558ecc552ea4ba61e5a74dec995738eec545d121718833a80  lua-CodeGen-0.3.3/COPYRIGHT
diff --git a/package/lua-codegen/lua-codegen.mk b/package/lua-codegen/lua-codegen.mk
new file mode 100644 (file)
index 0000000..caa9008
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# lua-codegen
+#
+################################################################################
+
+LUA_CODEGEN_VERSION = 0.3.3-1
+LUA_CODEGEN_NAME_UPSTREAM = lua-CodeGen
+LUA_CODEGEN_LICENSE = MIT
+LUA_CODEGEN_LICENSE_FILES = $(LUA_CODEGEN_SUBDIR)/COPYRIGHT
+
+$(eval $(luarocks-package))