tn5250: fix static build with openssl
authorBaruch Siach <baruch@tkos.co.il>
Wed, 26 Aug 2015 11:35:28 +0000 (14:35 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Aug 2015 11:53:09 +0000 (13:53 +0200)
OpenSSL needs libz. Use pkg-config to find dependencies.

Fixes:
http://autobuild.buildroot.net/results/95f/95f6df0d01e4944ecd84e830e2bbd8389e1d3e3d/
http://autobuild.buildroot.net/results/432/432b1fdec1e6282d51ba1d859c0f4ab9ed2a5efc/
http://autobuild.buildroot.net/results/d6a/d6a7125c21b4f92b69bb9e30b05c4727eedb63ba/

and more.

[Thomas: use += instead of = when assigning <pkg>_CONF_ENV to avoid
future mistakes.]

Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tn5250/tn5250.mk

index 213f02cb68e8c91d5d4b5c206663b9e74698cd1f..bbaa686d860a02bcfcbbd211aaa22ae217f07484 100644 (file)
@@ -13,7 +13,8 @@ TN5250_LICENSE_FILES = COPYING
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 TN5250_CONF_OPTS += --with-ssl-dir=$(STAGING_DIR)/usr
-TN5250_DEPENDENCIES += openssl
+TN5250_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs openssl`"
+TN5250_DEPENDENCIES += openssl host-pkgconf
 else
 TN5250_CONF_OPTS += --without-ssl
 endif