package/nodejs: remove icu support from 0.10.x
authorMartin Bark <martin@barkynet.com>
Thu, 9 Jun 2016 08:48:33 +0000 (09:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Jun 2016 08:51:01 +0000 (10:51 +0200)
icu support was added to nodejs in commit 7d0702a, however, 0.10.x does
not have support for icu. The 0.10.x configure script will error
if it is passed the --with-intl option.  This commit removes icu support
from 0.10.x.

Fixes:
 http://autobuild.buildroot.net/results/932e4ec24623592255f234a098f7a90ef2ad8063

Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nodejs/nodejs.mk

index efd9308a8d18c1c3cffb8c063d509d950912ce22..d6f115a51068cbfe1e532bbec2bebf54191f1816 100644 (file)
@@ -27,12 +27,15 @@ else
 NODEJS_CONF_OPTS += --without-ssl
 endif
 
+# 0.10.x does not have icu support
+ifeq ($(findstring 0.10.,$(NODEJS_VERSION)),)
 ifeq ($(BR2_PACKAGE_ICU),y)
 NODEJS_DEPENDENCIES += icu
 NODEJS_CONF_OPTS += --with-intl=system-icu
 else
 NODEJS_CONF_OPTS += --with-intl=none
 endif
+endif
 
 ifneq ($(BR2_PACKAGE_NODEJS_NPM),y)
 NODEJS_CONF_OPTS += --without-npm