gst-plugins-base: make alsa plug-in configurable
authorSven Neumann <s.neumann@raumfeld.com>
Thu, 20 Dec 2012 00:49:26 +0000 (00:49 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Jan 2013 11:55:48 +0000 (12:55 +0100)
It may be desirable not to use the alsa sink for playback
even though alsa-lib is installed. So make this a configuration
option. This also takes care of selecting the proper options
for alsa-lib
(BR2_PACKAGE_ALSA_LIB_MIXER and BR2_PACKAGE_ALSA_LIB_PCM).

[Peter: fix indentation]
Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-base/Config.in
package/multimedia/gst-plugins-base/gst-plugins-base.mk

index 5d8253395a6a10e7762ff339ac3a1c62ec91be06..af4fe8c1e0ac880d7a87479ab08b81d9fdede570 100644 (file)
@@ -73,6 +73,12 @@ config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_VOLUME
 
 comment "plugins with external dependencies (there may be more available)"
 
+config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ALSA
+       bool "alsa (mandatory for audio playback)"
+       select BR2_PACKAGE_ALSA_LIB
+       select BR2_PACKAGE_ALSA_LIB_MIXER
+       select BR2_PACKAGE_ALSA_LIB_PCM
+
 config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_OGG
        bool "ogg (*.ogg audio/video)"
        select BR2_PACKAGE_LIBOGG
index b044516cc06b7370bb777e12bb53c718da0638c9..02e7ca41c8824a0b396228bda8023db6e61694c0 100644 (file)
@@ -40,8 +40,7 @@ ifeq ($(BR2_PACKAGE_ORC),y)
 GST_PLUGINS_BASE_DEPENDENCIES += orc
 endif
 
-# alsa support needs pcm+mixer support, but configure fails to check for it
-ifeq ($(BR2_PACKAGE_ALSA_LIB)$(BR2_PACKAGE_ALSA_LIB_MIXER)$(BR2_PACKAGE_ALSA_LIB_PCM),yyy)
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_ALSA),y)
 GST_PLUGINS_BASE_DEPENDENCIES += alsa-lib
 else
 GST_PLUGINS_BASE_CONF_OPT += --disable-alsa