xinetd: fix build without RPC support
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Jun 2012 20:58:26 +0000 (22:58 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 16 Jun 2012 20:58:26 +0000 (22:58 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/xinetd/Config.in
package/xinetd/xinetd.mk

index 6bfe24ca428df057891bff3314fcf06473472813..76fe603547bd530e5cc84c89245ba0ef5fcb31b1 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_XINETD
        bool "xinetd"
-       depends on BR2_INET_RPC
        help
          xinetd is a secure replacement for inetd. It was originally written by
          panos@cs.colorado.edu.
index 2ab25462703d5f4c66feceb89e2e4d202206de78..6a69a554ebdbff392da9d324c7675ee43ece56e4 100644 (file)
@@ -7,4 +7,8 @@ XINETD_VERSION = 2.3.15
 XINETD_SOURCE  = xinetd-$(XINETD_VERSION).tar.gz
 XINETD_SITE    = http://www.xinetd.org
 
+ifneq ($(BR2_INET_RPC),y)
+XINETD_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DNO_RPC"
+endif
+
 $(eval $(call AUTOTARGETS))