Stop referencing the crazy target/device stuff
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 5 Dec 2010 20:52:40 +0000 (21:52 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 16 Dec 2010 11:15:52 +0000 (12:15 +0100)
We don't need Config.in and Makefile in target/device: defconfig files
are sufficient to describe the specificities of a board (architecture,
compilation flags, bootloader and kernel details, etc.).

However, a placeholder such as target/device will be kept in order to
host things such as kernel configuration files or various
board-specific patches.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Config.in
target/Makefile.in

index de4ff4ae1be75e2e33779d4d0205e6f69b2c122a..874c20abd1760136264fbccb30c3691b60df757c 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -11,7 +11,6 @@ config BR2_VERSION
        option env="BR2_VERSION_FULL"
 
 source "target/Config.in.arch"
-source "target/device/Config.in"
 
 menu "Build options"
 
index aab9d39b933094556148c95286fcbeeb506c1576..915d62538cd03275282be357179fcdd13328d8d7 100644 (file)
@@ -1,6 +1,3 @@
 # make sure to put everything that is board-specific before the tarroot targets
 include target/generic/Makefile.in
 
-# this eventually adds the kernel target to TARGETS:
-include target/device/Makefile.in
-include target/xtensa/Makefile.in