python-bottle: convert to the Python package infrastructure
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Dec 2013 20:26:37 +0000 (21:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 12:34:02 +0000 (13:34 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python-bottle/python-bottle.mk

index db71512ec4a7810b56c90d27381aa309a603facb..58c51f95c2c81a1a1c25bf5eb3e9455ef94a09cf 100644 (file)
@@ -7,16 +7,8 @@
 PYTHON_BOTTLE_VERSION = 0.11.6
 PYTHON_BOTTLE_SOURCE = bottle-$(PYTHON_BOTTLE_VERSION).tar.gz
 PYTHON_BOTTLE_SITE = http://pypi.python.org/packages/source/b/bottle
-PYTHON_BOTTLE_DEPENDENCIES = python
 PYTHON_BOTTLE_LICENSE = MIT
 # README.rst refers to the file "LICENSE" but it's not included
+PYTHON_BOTTLE_SETUP_TYPE = distutils
 
-define PYTHON_BOTTLE_BUILD_CMDS
-       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build --executable=/usr/bin/python)
-endef
-
-define PYTHON_BOTTLE_INSTALL_TARGET_CMDS
-       (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
-endef
-
-$(eval $(generic-package))
+$(eval $(python-package))