package/smartmontools: fix build without stack-protector
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 23 Feb 2020 15:36:38 +0000 (16:36 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 23 Feb 2020 18:25:09 +0000 (19:25 +0100)
Fixes:
 - http://autobuild.buildroot.org/results/0de9f2a69fa2a39164211299f8a429d2fec6935a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/smartmontools/0001-configure.ac-fix-stack-protector-detection.patch [new file with mode: 0644]
package/smartmontools/smartmontools.mk

diff --git a/package/smartmontools/0001-configure.ac-fix-stack-protector-detection.patch b/package/smartmontools/0001-configure.ac-fix-stack-protector-detection.patch
new file mode 100644 (file)
index 0000000..63f51fc
--- /dev/null
@@ -0,0 +1,38 @@
+From 6bd18b0b7b4d916e474ba84707eb784a643b3e71 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Sun, 23 Feb 2020 16:23:20 +0100
+Subject: [PATCH] configure.ac: fix stack-protector detection
+
+Use AC_LINK_IFELSE instead of AC_COMPILE_IFELSE to check for
+stack-protector availability as some compilers could missed the needed
+library (-lssp or -lssp_nonshared) at linking step:
+
+/home/giuliobenetti/autobuild/run/instance-3/output-1/host/bin/x86_64-linux-g++  -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64  -Os   -Wall -W -Wformat=2 -fstack-protector-strong   -o smartctl smartctl.o atacmdnames.o atacmds.o ataidentify.o ataprint.o dev_ata_cmd_set.o dev_intelliprop.o dev_interface.o dev_jmb39x_raid.o json.o knowndrives.o nvmecmds.o nvmeprint.o scsicmds.o scsiata.o scsinvme.o scsiprint.o utility.o     os_linux.o cciss.o dev_areca.o    -lselinux
+/home/giuliobenetti/autobuild/run/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/x86_64-buildroot-linux-uclibc/8.3.0/../../../../x86_64-buildroot-linux-uclibc/bin/ld: cannot find -lssp_nonshared
+/home/giuliobenetti/autobuild/run/instance-3/output-1/host/opt/ext-toolchain/bin/../lib/gcc/x86_64-buildroot-linux-uclibc/8.3.0/../../../../x86_64-buildroot-linux-uclibc/bin/ld: cannot find -lssp
+
+Fixes:
+ - http://autobuild.buildroot.org/results/0de9f2a69fa2a39164211299f8a429d2fec6935a
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://www.smartmontools.org/ticket/1302]
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 87470d8a..ccb457e1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -770,7 +770,7 @@ if test "$GXX" = "yes"; then
+     AC_MSG_CHECKING([whether $CXX supports $option])
+     save_CXXFLAGS=$CXXFLAGS
+     CXXFLAGS="$CXXFLAGS $option"
+-    AC_COMPILE_IFELSE([AC_LANG_PROGRAM()], [res=yes], [res=no; CXXFLAGS=$save_CXXFLAGS])
++    AC_LINK_IFELSE([AC_LANG_PROGRAM()], [res=yes], [res=no; CXXFLAGS=$save_CXXFLAGS])
+     AC_MSG_RESULT([$res])
+   done
+ else
+-- 
+2.25.0
+
index 77eedfabd8c0024c07f964382538f9cd2c0fc583..9dc2f789ccac759dca437d857a30df3914fd3cb1 100644 (file)
@@ -8,6 +8,8 @@ SMARTMONTOOLS_VERSION = 7.1
 SMARTMONTOOLS_SITE = http://downloads.sourceforge.net/project/smartmontools/smartmontools/$(SMARTMONTOOLS_VERSION)
 SMARTMONTOOLS_LICENSE = GPL-2.0+
 SMARTMONTOOLS_LICENSE_FILES = COPYING
+# We're patching configure.ac
+SMARTMONTOOLS_AUTORECONF = YES
 
 ifeq ($(BR2_PACKAGE_LIBCAP_NG),y)
 SMARTMONTOOLS_CONF_OPTS += --with-libcap-ng