Revert "package/bitcoin: unset the NDEBUG flag"
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 4 Jul 2021 11:43:28 +0000 (13:43 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 4 Jul 2021 19:38:25 +0000 (21:38 +0200)
Setting NDEBUG is no longer done by the infra.

This reverts commit f098aff4792a0e792bda4d7d1ec22a5af1381d83.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/bitcoin/bitcoin.mk

index f485e4ee5ca13863f380111cbcc55f9a504d7c86..142521835c1b9038dc680dbeea4bbcc221691efc 100644 (file)
@@ -13,12 +13,6 @@ BITCOIN_CPE_ID_VENDOR = bitcoin
 BITCOIN_CPE_ID_PRODUCT = bitcoin_core
 BITCOIN_DEPENDENCIES = host-pkgconf boost libevent
 BITCOIN_MAKE_ENV = BITCOIN_GENBUILD_NO_GIT=1
-# Bitcoin is using assert(...) extensively with the assumption of it
-# never being a noop at runtime. So we cannot build with NDEBUG.
-BITCOIN_CONF_ENV = \
-       CPPFLAGS="$(TARGET_CPPFLAGS) -UNDEBUG" \
-       CFLAGS="$(TARGET_CFLAGS) -UNDEBUG" \
-       CXXFLAGS="$(TARGET_CXXFLAGS) -UNDEBUG"
 BITCOIN_CONF_OPTS = \
        --disable-bench \
        --disable-wallet \