kmod: annotate licenses with components
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>
Wed, 19 Oct 2016 17:41:54 +0000 (23:11 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 19 Oct 2016 21:28:09 +0000 (23:28 +0200)
library libkmod.so is licensed under LGPLv2.1+ and kmod tools are
licensed under GPLv2+.

Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kmod/kmod.mk

index 1753b1d5eb12cff35ab045cc8e6437c0d6d53754..7492b926f0c343a2efe7fc8941603ffbdfa66194 100644 (file)
@@ -12,7 +12,7 @@ KMOD_DEPENDENCIES = host-pkgconf
 HOST_KMOD_DEPENDENCIES = host-pkgconf
 
 # license info for libkmod only, conditionally add more below
-KMOD_LICENSE = LGPLv2.1+
+KMOD_LICENSE = LGPLv2.1+ (library)
 KMOD_LICENSE_FILES = libkmod/COPYING
 
 # static linking not supported, see
@@ -40,7 +40,7 @@ endif
 ifeq ($(BR2_PACKAGE_KMOD_TOOLS),y)
 
 # add license info for kmod tools
-KMOD_LICENSE += GPLv2+
+KMOD_LICENSE := $(KMOD_LICENSE), GPLv2+ (tools)
 KMOD_LICENSE_FILES += COPYING
 
 # take precedence over busybox implementation