package/gmp: enable C++ support when BR2_INSTALL_LIBSTDCPP=y
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Thu, 5 Sep 2019 13:40:40 +0000 (15:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 7 Sep 2019 13:03:04 +0000 (15:03 +0200)
gmp has optional C++ support, which is disabled by default. Let's
enabled it conditionally depending on the BR2_INSTALL_LIBSTDCPP
option.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gmp/gmp.mk

index 7236e37bb4bc0ea4e13b000355f3cda39cc4760f..d124463a98a3af07b8896b6743e4bc9aa3865766 100644 (file)
@@ -19,5 +19,11 @@ ifeq ($(BR2_m68k_cf)$(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6)$(BR2_ARM_CP
 GMP_CONF_OPTS += --disable-assembly
 endif
 
+ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
+GMP_CONF_OPTS += --enable-cxx
+else
+GMP_CONF_OPTS += --disable-cxx
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))