Fix building initramfs kernel with appended dtb
authorNathan Ford <nford@westpond.com>
Wed, 31 Jul 2013 15:47:36 +0000 (11:47 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 1 Aug 2013 15:38:44 +0000 (17:38 +0200)
The target for building the kernel with a cpio initramfs is not
calling the append dtb commands, creating a final kernel image
without an appended dtb. Instead it needs to call kernel make on
the intermediate target, then call the append dtb commands
to produce the final image as the primary kernel build target
does.

Signed-off-by: Nathan Ford <nford@westpond.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 780d6d5e613ce74c098cf331313c54bdb06c6077..fc379ec49902cae2baf7807a5e0dbdfea70d62d7 100644 (file)
@@ -313,6 +313,7 @@ $(LINUX_DIR)/.stamp_initramfs_rebuilt: $(LINUX_DIR)/.stamp_target_installed $(LI
        @$(call MESSAGE,"Rebuilding kernel with initramfs")
        # Build the kernel.
        $(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(LINUX_IMAGE_NAME)
+       $(LINUX_APPEND_DTB)
        # Copy the kernel image to its final destination
        cp $(LINUX_IMAGE_PATH) $(BINARIES_DIR)
        # If there is a .ub file copy it to the final destination