wireshark: add lz4 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Nov 2018 10:10:29 +0000 (11:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 6 Nov 2018 23:21:21 +0000 (00:21 +0100)
- Optional dependency to lz4 has been added with version 2.4.0 and
  https://github.com/wireshark/wireshark/commit/47649d1c7fb6ba48b805e19268a711404eb6908b
- Specify the path to found lz4 as this is done for other options

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wireshark/wireshark.mk

index 96cc15d1854d828f398ff7bca64632ebcbc6716b..f42dca1c864ff5447d897c0ae72143c3a8616ccf 100644 (file)
@@ -16,7 +16,6 @@ WIRESHARK_CONF_ENV = \
 
 WIRESHARK_CONF_OPTS = \
        --enable-static=no \
-       --without-lz4 \
        --without-snappy \
        --with-libsmi=no \
        --with-pcap=$(STAGING_DIR)/usr
@@ -115,6 +114,13 @@ else
 WIRESHARK_CONF_OPTS += --without-lua
 endif
 
+ifeq ($(BR2_PACKAGE_LZ4),y)
+WIRESHARK_CONF_OPTS += --with-lz4=$(STAGING_DIR)/usr
+WIRESHARK_DEPENDENCIES += lz4
+else
+WIRESHARK_CONF_OPTS += --without-lz4
+endif
+
 ifeq ($(BR2_PACKAGE_NGHTTP2),y)
 WIRESHARK_CONF_OPTS += --with-nghttp2=$(STAGING_DIR)/usr
 WIRESHARK_DEPENDENCIES += nghttp2