setools: fix race condition
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 10 Sep 2015 15:58:25 +0000 (16:58 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 10 Sep 2015 20:07:30 +0000 (22:07 +0200)
As reported upstream:

  https://github.com/TresysTechnology/setools3/issues/5

setools tries to compile a .c file before being generated and then it
produces an error like this one:

error: policy_scan.c: No such file or directory

Until upstream fixes the problem we can workaround this by using MAKE1
as the SETOOLS_MAKE.

Fixes:

  http://autobuild.buildroot.net/results/119/1196ac448c77320b59b63b6133d2d1af1245bf69/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/setools/setools.mk

index a2bfd420e515eeb755303dd95bfd0fd98dc0c13c..71301c78a9399f358828ae7f0f279bbcbfbb31ef 100644 (file)
@@ -12,6 +12,10 @@ SETOOLS_INSTALL_STAGING = YES
 SETOOLS_LICENSE = GPLv2+ LGPLv2.1+
 SETOOLS_LICENSE_FILES = COPYING COPYING.GPL COPYING.LGPL
 
+# Race condition reported upstream:
+# https://github.com/TresysTechnology/setools3/issues/5
+SETOOLS_MAKE = $(MAKE1)
+
 # configure.ac is patched by the cross compile patch,
 # so autoreconf is necessary
 SETOOLS_AUTORECONF = YES