neardal: properly quote output of pkg-config
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 21 May 2015 22:04:32 +0000 (00:04 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 21 May 2015 22:04:32 +0000 (00:04 +0200)
Commit 5504039c4e (neardal: fix readline/libedit detection with static
linking) added the output of pkg-config to the LIBS shell variable without
adding quotes around it, breaking the logic if the output would ever consist
of more than 1 word.

Now, pkg-config --libs ncurses currently only outputs '-lncurses', so
nothing is really broken (for now atleast), but lets add the quotes before
it does or the syntax gets copied somewhere else where it does.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/neardal/neardal.mk

index c65a5e6169aad930af10e20eb95c33b9c3d84cfe..ddaecbeb1252c6046c35a54cbfd7720fe24e2ad5 100644 (file)
@@ -25,7 +25,7 @@ endif
 # forgets to take that into account, causing the detection to fail
 # when linking statically
 ifeq ($(BR2_STATIC_LIBS),y)
-NEARDAL_CONF_ENV += LIBS=$(shell $(PKG_CONFIG_HOST_BINARY) --libs ncurses)
+NEARDAL_CONF_ENV += LIBS='$(shell $(PKG_CONFIG_HOST_BINARY) --libs ncurses)'
 endif
 
 define NEARDAL_INSTALL_NCL