package/snort: needs zlib
authorPeter Seiderer <ps.report@gmx.net>
Fri, 10 Jan 2020 17:28:17 +0000 (18:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Jan 2020 14:49:32 +0000 (15:49 +0100)
In commit fe4b9321e5ef3594776bba443d9718efd766f40e ("package/libpcap:
remove unnecessary dependency on zlib"), the depedency of libpcap on
zlib was removed as it was not needed. However, it was thanks to this
dependency that the snort package satisfied its dependency on zlib,
which is now missing. This commit fixes that by adding a dependency of
snort on zlib.

Fixes:

  checking zlib.h usability... no
  checking zlib.h presence... no
  checking for zlib.h... no

     ERROR!  zlib header not found, go get it from
     http://www.zlib.net

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/snort/Config.in
package/snort/snort.mk

index 7d2c52c3f321d4ef21fda2ce1ec47e13f4a5c3a3..fc74efcfedf56f75d626c9c95262f3d6938c4c14 100644 (file)
@@ -9,6 +9,7 @@ config BR2_PACKAGE_SNORT
        select BR2_PACKAGE_DAQ
        select BR2_PACKAGE_PCRE
        select BR2_PACKAGE_LIBTIRPC if !BR2_TOOLCHAIN_HAS_NATIVE_RPC
+       select BR2_PACKAGE_ZLIB
        help
          Snort is a free and open source network intrusion
          prevention system (IPS) and network intrusion detection
index 024c94162bff597934bfe2da93bff107e72ba94d..4006d176bf88595bc65283b933dc2701f39b1de0 100644 (file)
@@ -9,7 +9,7 @@ SNORT_SITE = https://www.snort.org/downloads/snort
 SNORT_LICENSE = GPL-2.0
 SNORT_LICENSE_FILES = LICENSE COPYING
 
-SNORT_DEPENDENCIES = libpcap libdnet daq pcre host-pkgconf
+SNORT_DEPENDENCIES = libpcap libdnet daq pcre zlib host-pkgconf
 
 # patching configure.in
 SNORT_AUTORECONF = YES