package/qemu: Compare host/target Linux version only during build phase
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 21 May 2015 08:47:23 +0000 (10:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 21 May 2015 20:56:21 +0000 (22:56 +0200)
This patch fixes an error during source-check.

Thanks to Thomas for the hint:
http://article.gmane.org/gmane.comp.lib.uclibc.buildroot/116183

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qemu/qemu.mk

index 04df79fcd5b83eb0c55b2133bc79f66df3bed372..0620804a00be54d21e3f3380a133cb6a687b0aa7 100644 (file)
@@ -85,10 +85,12 @@ HOST_QEMU_COMPARE_VERSION = $(shell test $(HOST_QEMU_HOST_SYSTEM_VERSION) -ge $(
 # built with kernel headers that are older or the same as the kernel
 # version running on the host machine.
 #
+ifeq ($(BR_BUILDING),y)
 ifneq ($(HOST_QEMU_COMPARE_VERSION),OK)
 $(error "Refusing to build qemu-user: target Linux version newer than host's.")
 endif
 endif
+endif
 
 define HOST_QEMU_CONFIGURE_CMDS
        cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure    \