mpd: add mms support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 7 Apr 2018 11:52:30 +0000 (13:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 28 Apr 2018 16:36:02 +0000 (18:36 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mpd/Config.in
package/mpd/mpd.mk

index 6c7468e173cca631f2a881128d0fbe9dcbe29a73..831e4ab0d7296f4931f9f05c3c193f6853022bf6 100644 (file)
@@ -180,6 +180,12 @@ config BR2_PACKAGE_MPD_CURL
        help
          Enable curl streaming (http) support.
 
+config BR2_PACKAGE_MPD_LIBMMS
+       bool "mms"
+       select BR2_PACKAGE_LIBMMS
+       help
+         Enable MMS support.
+
 config BR2_PACKAGE_MPD_LIBNFS
        bool "nfs"
        # libnfs -> libtirpc
index 639c8c198158be4b409566b53fc47df588d4665e..64471d4da5e902d31bcb51004e253524e4978ef0 100644 (file)
@@ -120,6 +120,13 @@ else
 MPD_CONF_OPTS += --disable-libmpdclient
 endif
 
+ifeq ($(BR2_PACKAGE_MPD_LIBMMS),y)
+MPD_DEPENDENCIES += libmms
+MPD_CONF_OPTS += --enable-mms
+else
+MPD_CONF_OPTS += --disable-mms
+endif
+
 ifeq ($(BR2_PACKAGE_MPD_LIBNFS),y)
 MPD_DEPENDENCIES += libnfs
 MPD_CONF_OPTS += --enable-nfs