gvfs: bump to version 1.26.1.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 19 Oct 2015 13:33:58 +0000 (10:33 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 19 Oct 2015 20:10:17 +0000 (22:10 +0200)
Lots of changes, add support for libnfs, udev, libbluray, cleanup afp
support, gtk3, and systemd.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gvfs/Config.in
package/gvfs/gvfs.hash
package/gvfs/gvfs.mk

index 5e0191821923bbb948716b96b3684add24dba819..44a75210e52852be5f20e5f443b63bbbe4d810ba 100644 (file)
@@ -13,7 +13,7 @@ config BR2_PACKAGE_GVFS
          all applications using the gio API. It also supports exposing
          the gvfs mounts to non-gio applications using fuse.
 
-         http://en.wikipedia.org/wiki/GVFS
+         https://wiki.gnome.org/action/show/Projects/gvfs
 
 comment "gvfs needs a toolchain w/ wchar, threads"
        depends on BR2_USE_MMU
index df21790935025cd41700e82b53fbb3c64a8c99d9..cc9e4f640385e740cf8cd3bec23f416ee0b70894 100644 (file)
@@ -1,2 +1,2 @@
-# From http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.16/gvfs-1.16.2.sha256sum
-sha256 6b0e62d27fe73844efb536689057b762fbce085984800c83395371306ec547f1        gvfs-1.16.2.tar.xz
+# From http://ftp.gnome.org/pub/GNOME/sources/gvfs/1.26/gvfs-1.26.1.1.sha256sum
+sha256 2dadf986e464db1d7f007b178a5432b30ba93ef0cb31a2795156540d496dc06d        gvfs-1.26.1.1.tar.xz
index 4242e801bf9b3820ffb88ba29bd9ba5022c5234a..e1da18fb5140e4c40332e2fdd058fddbe0563be4 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-GVFS_VERSION_MAJOR = 1.16
-GVFS_VERSION = $(GVFS_VERSION_MAJOR).2
+GVFS_VERSION_MAJOR = 1.26
+GVFS_VERSION = $(GVFS_VERSION_MAJOR).1.1
 GVFS_SOURCE = gvfs-$(GVFS_VERSION).tar.xz
 GVFS_SITE = http://ftp.gnome.org/pub/GNOME/sources/gvfs/$(GVFS_VERSION_MAJOR)
 GVFS_INSTALL_STAGING = YES
@@ -17,14 +17,21 @@ GVFS_LICENSE_FILES = COPYING
 # build system from searching the host paths.
 GVFS_CONF_ENV = ac_cv_path_LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
 
+# Most of these are missing library support
 GVFS_CONF_OPTS = \
-       --disable-gconf                 \
-       --disable-cdda                  \
-       --disable-obexftp               \
-       --disable-gphoto2               \
-       --disable-keyring               \
-       --disable-bash-completion       \
-       --disable-hal
+       --disable-afc \
+       --disable-bash-completion \
+       --disable-cdda \
+       --disable-gconf \
+       --disable-gcr \
+       --disable-gdu \
+       --disable-goa \
+       --disable-google \
+       --disable-gphoto2 \
+       --disable-hal \
+       --disable-keyring \
+       --disable-libmtp \
+       --disable-udisks2
 
 ifeq ($(BR2_PACKAGE_AVAHI),y)
 GVFS_DEPENDENCIES += avahi
@@ -33,13 +40,31 @@ else
 GVFS_CONF_OPTS += --disable-avahi
 endif
 
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+GVFS_DEPENDENCIES += udev
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGUDEV),y)
+GVFS_DEPENDENCIES += libgudev
+endif
+
 ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
 GVFS_DEPENDENCIES += libarchive
-GVFS_CONF_OPTS += --enable-archive
+GVFS_CONF_OPTS += \
+       --enable-archive \
+       --with-archive-includes=$(STAGING_DIR)/usr \
+       --with-archive-libs=$(STAGING_DIR)/usr
 else
 GVFS_CONF_OPTS += --disable-archive
 endif
 
+ifeq ($(BR2_PACKAGE_LIBBLURAY),y)
+GVFS_DEPENDENCIES += libbluray
+GVFS_CONF_OPTS += --enable-bluray
+else
+GVFS_CONF_OPTS += --disable-bluray
+endif
+
 ifeq ($(BR2_PACKAGE_LIBFUSE),y)
 GVFS_DEPENDENCIES += libfuse
 GVFS_CONF_OPTS += --enable-fuse
@@ -47,8 +72,26 @@ else
 GVFS_CONF_OPTS += --disable-fuse
 endif
 
+# AFP support is anon-only without libgcrypt which isn't very useful
 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+GVFS_CONF_OPTS += --enable-afp
 GVFS_DEPENDENCIES += libgcrypt
+else
+GVFS_CONF_OPTS += --disable-afp
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGTK3),y)
+GVFS_CONF_OPTS += --enable-gtk
+GVFS_DEPENDENCIES += libgtk3
+else
+GVFS_CONF_OPTS += --disable-gtk
+endif
+
+ifeq ($(BR2_PACKAGE_LIBNFS),y)
+GVFS_CONF_OPTS += --enable-nfs
+GVFS_DEPENDENCIES += libnfs
+else
+GVFS_CONF_OPTS += --disable-nfs
 endif
 
 ifeq ($(BR2_PACKAGE_LIBSOUP),y)
@@ -69,6 +112,12 @@ else
 GVFS_CONF_OPTS += --disable-samba
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+GVFS_DEPENDENCIES += systemd
+else
+GVFS_CONF_OPTS += --disable-libsystemd-login
+endif
+
 define GVFS_REMOVE_USELESS_BINARY
        rm $(TARGET_DIR)/usr/bin/gvfs-less
 endef