libfm: new package
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 21 Nov 2014 15:33:09 +0000 (15:33 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 00:16:09 +0000 (02:16 +0200)
[Thomas:
  - switch from 'select BR2_PACKAGE_XORG7' to 'depends on
    BR2_PACKAGE_XORG7' as suggested by Yann E. Morin.
  - add LGPLv2.1+ in the list of licenses as well as a corresponding
    license file, as suggested by Yann E. Morin.]

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libfm/Config.in [new file with mode: 0644]
package/libfm/libfm.hash [new file with mode: 0644]
package/libfm/libfm.mk [new file with mode: 0644]

index 8a204b4cf58b5e7440d08e36e88efebf312dfbd5..ffa0aecd9136b0ae17c24733ca1ef962dd79f664 100644 (file)
@@ -786,6 +786,7 @@ menu "Graphics"
        source "package/libdri2/Config.in"
        source "package/libdrm/Config.in"
        source "package/libexif/Config.in"
+       source "package/libfm/Config.in"
        source "package/libfm-extra/Config.in"
        source "package/libfreeimage/Config.in"
        source "package/libgail/Config.in"
diff --git a/package/libfm/Config.in b/package/libfm/Config.in
new file mode 100644 (file)
index 0000000..c6cfcf6
--- /dev/null
@@ -0,0 +1,28 @@
+config BR2_PACKAGE_LIBFM
+       bool "libfm"
+       select BR2_PACKAGE_MENU_CACHE
+       select BR2_PACKAGE_LIBGLIB2
+       select BR2_PACKAGE_LIBGTK2
+       select BR2_PACKAGE_CAIRO
+       depends on BR2_PACKAGE_XORG7
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       depends on BR2_INSTALL_LIBSTDCPP # libgtk2
+       depends on BR2_ARCH_HAS_ATOMICS # libgtk2
+       help
+         A glib/gio-based library providing some file management
+         utilities and related-widgets missing in gtk+/glib. This is
+         the core of PCManFM.  The library is desktop independent
+         (not LXDE specific) and has clean API. It can be used to
+         develop other applications requiring file management
+         functionality. For example, you can create your own file
+         manager with facilities provided by libfm.
+
+         http://wiki.lxde.org/en/Libfm
+
+comment "libfm needs X.org and a toolchain w/ wchar, threads, C++"
+       depends on BR2_USE_MMU
+       depends on BR2_ARCH_HAS_ATOMICS
+       depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_HAS_THREADS || !BR2_PACKAGE_XORG7
diff --git a/package/libfm/libfm.hash b/package/libfm/libfm.hash
new file mode 100644 (file)
index 0000000..5311dec
--- /dev/null
@@ -0,0 +1,2 @@
+# From http://blog.lxde.org/?p=1280
+sha1  c3f2f34086761d89d6aba549883610084ba00750  libfm-1.2.3.tar.xz
diff --git a/package/libfm/libfm.mk b/package/libfm/libfm.mk
new file mode 100644 (file)
index 0000000..f0888b7
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# libfm
+#
+################################################################################
+
+LIBFM_VERSION = 1.2.3
+LIBFM_SOURCE = libfm-$(LIBFM_VERSION).tar.xz
+LIBFM_SITE = http://sourceforge.net/projects/pcmanfm/files
+LIBFM_DEPENDENCIES = menu-cache libgtk2 libglib2 cairo
+LIBFM_LICENSE = GPLv2+, LGPLv2.1+
+LIBFM_LICENSE_FILES = COPYING src/extra/fm-xml-file.c
+LIBFM_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))