uclibc: do not use GENERATE_LOCALE
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Nov 2014 22:17:24 +0000 (23:17 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 21 Nov 2014 20:50:38 +0000 (21:50 +0100)
Since commit 33de7401701e5242196a86b0695ee4ae9a4c4082 ("Makefile:
convert "target-generatelocales" to a hook"), the GENERATE_LOCALE
variable is never defined when using uClibc. This means that setting
any value to the BR2_GENERATE_LOCALE option had no effect for uClibc
toolchains.

In this commit, we make sure the uclibc.mk logic re-creates its own
qstripped version of BR2_GENERATE_LOCALE, in a variable called
UCLIBC_GENERATE_LOCALES.

This fixes locale generation with uClibc in the internal toolchain
backend.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/uclibc.mk

index ce416dd54367a542bc0eadb2d96a46eedf0bc59a..2d95ce1f4d6c39cf3d3fb991eda73a11fdc8c423 100644 (file)
@@ -47,12 +47,14 @@ UCLIBC_KCONFIG_OPTS = \
 
 UCLIBC_TARGET_ARCH = $(call qstrip,$(BR2_UCLIBC_TARGET_ARCH))
 
-ifeq ($(GENERATE_LOCALE),)
+UCLIBC_GENERATE_LOCALES = $(call qstrip,$(BR2_GENERATE_LOCALE))
+
+ifeq ($(UCLIBC_GENERATE_LOCALES),)
 # We need at least one locale
 UCLIBC_LOCALES = en_US
 else
 # Strip out the encoding part of locale names, if any
-UCLIBC_LOCALES = $(foreach locale,$(GENERATE_LOCALE),\
+UCLIBC_LOCALES = $(foreach locale,$(UCLIBC_GENERATE_LOCALES),\
                   $(firstword $(subst .,$(space),$(locale))))
 endif