package/sunxi-mali-mainline-driver: bear the kernel options munging
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 4 Apr 2020 12:10:29 +0000 (14:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 1 May 2020 13:50:29 +0000 (15:50 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/linux.mk
package/sunxi-mali-mainline-driver/sunxi-mali-mainline-driver.mk

index ca5dd692d78dee6e8ac3ebd8a4698c484bc44ed8..8867be44f7b903f963a37412cc390bd09e6d0742 100644 (file)
@@ -357,9 +357,6 @@ define LINUX_KCONFIG_FIXUP_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_NET))
        $(if $(BR2_PACKAGE_LINUX_TOOLS_PERF),
                $(call KCONFIG_ENABLE_OPT,CONFIG_PERF_EVENTS))
-       $(if $(BR2_PACKAGE_SUNXI_MALI_MAINLINE_DRIVER),
-               $(call KCONFIG_ENABLE_OPT,CONFIG_CMA)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_DMA_CMA))
        $(if $(BR2_PACKAGE_IPTABLES),
                $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_IPTABLES)
                $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_FILTER)
index 0edcdee4d64a7425d9b9262a00105bc42a4c09ce..40ea450b316dee70adfe3274af6760ec1108a993 100644 (file)
@@ -32,4 +32,9 @@ define SUNXI_MALI_MAINLINE_DRIVER_INSTALL_TARGET_CMDS
                $(SHELL) ./build.sh -r $(SUNXI_MALI_MAINLINE_REV) -j $(PARALLEL_JOBS) -i
 endef
 
+define SUNXI_MALI_MAINLINE_DRIVER_LINUX_CONFIG_FIXUPS
+       $(call KCONFIG_ENABLE_OPT,CONFIG_CMA)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_DMA_CMA)
+endef
+
 $(eval $(generic-package))