package/gstreamer1/gst1-plugins-base: fix dispmanx option
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 17 Aug 2019 12:24:02 +0000 (14:24 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 20 Aug 2019 11:20:12 +0000 (13:20 +0200)
There is a typo in the handling of the
BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_DISPMANX option: we're adding
dispmax to GST1_PLUGINS_BASE_WINSYS_LIST, which causes the following
build failure:

meson.build:1:0: ERROR: Options "dispmax" are not in allowed choices: "x11, wayland, win32, cocoa, dispmanx, viv-fb, gbm, auto"

We fix this by using the proper option name, "dispmanx" instead of the
slightly incorrect "dispmax".

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-base/gst1-plugins-base.mk

index 66c136c36c5d1085e523aacc405295242f349762..90d2478bbcdfc914094b921e91add7caac53d3b0 100644 (file)
@@ -74,7 +74,7 @@ GST1_PLUGINS_BASE_DEPENDENCIES += wayland wayland-protocols
 endif
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_DISPMANX),y)
-GST1_PLUGINS_BASE_WINSYS_LIST += dispmax
+GST1_PLUGINS_BASE_WINSYS_LIST += dispmanx
 GST1_PLUGINS_BASE_DEPENDENCIES += rpi-userland
 endif
 GST1_PLUGINS_BASE_CONF_OPTS += -Dgl_winsys='$(subst $(space),$(comma),$(GST1_PLUGINS_BASE_WINSYS_LIST))'