package/ffmpeg: add optional support for opencv3
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 5 Sep 2016 14:51:20 +0000 (16:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 6 Sep 2016 19:39:22 +0000 (21:39 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ffmpeg/ffmpeg.mk

index a90d437e4fa1a74bd5cffe3e07ad34b660ae1741..782d913e6828f850a697689c220c1642790ed11d 100644 (file)
@@ -253,6 +253,9 @@ endif
 ifeq ($(BR2_PACKAGE_OPENCV_LIB_IMGPROC)x$(BR2_PACKAGE_OPENCV_WITH_FFMPEG),yx)
 FFMPEG_CONF_OPTS += --enable-libopencv
 FFMPEG_DEPENDENCIES += opencv
+else ifeq ($(BR2_PACKAGE_OPENCV3_LIB_IMGPROC)x$(BR2_PACKAGE_OPENCV3_WITH_FFMPEG),yx)
+FFMPEG_CONF_OPTS += --enable-libopencv
+FFMPEG_DEPENDENCIES += opencv3
 else
 FFMPEG_CONF_OPTS += --disable-libopencv
 endif