package/perf: use correct definition of ARCH on x86_64
authorSteven Noonan <steven@uplinklabs.net>
Tue, 14 Jul 2015 17:35:11 +0000 (19:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 21:17:25 +0000 (23:17 +0200)
LINUX_MAKE_FLAGS defines ARCH=$(KERNEL_ARCH), and KERNEL_ARCH is x86_64 on
a 64-bit x86 kernel build. The perf Makefiles expect that the ARCH will be
"x86" on both 32-bit x86 and 64-bit x86.

I didn't experience issues with the Linux 3.14.x version of perf, but this
issue cropped up once I started building 3.19.x.

Signed-off-by: Steven Noonan <steven@uplinklabs.net>
[Romain:
  - fix coding style]
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perf/perf.mk

index 42fbe249cd4df081a5878e5e83a8805756f4873b..2bdd555a414eebd7932c3adbde1239edc43458f3 100644 (file)
@@ -10,8 +10,15 @@ PERF_VERSION = $(call qstrip,$(BR2_LINUX_KERNEL_VERSION))
 
 PERF_DEPENDENCIES = linux host-flex host-bison
 
+ifeq ($(KERNEL_ARCH),x86_64)
+PERF_ARCH=x86
+else
+PERF_ARCH=$(KERNEL_ARCH)
+endif
+
 PERF_MAKE_FLAGS = \
        $(LINUX_MAKE_FLAGS) \
+       ARCH=$(PERF_ARCH) \
        NO_LIBAUDIT=1 \
        NO_NEWT=1 \
        NO_GTK2=1 \