openssl: adjust ARM optimizations
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 4 Apr 2013 07:29:46 +0000 (07:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 11 Apr 2013 07:25:51 +0000 (09:25 +0200)
We no longer support ARM less than v4 so just kill dead code that we had
for those cases.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/openssl/openssl.mk

index 96f817d2b262fc9c2584552ee2facaffcbb09e7a..7701d5159d83c67d1f3c69b5dff2de482276647c 100644 (file)
@@ -29,14 +29,8 @@ endif
 
 # Some architectures are optimized in OpenSSL
 ifeq ($(ARCH),arm)
-ifneq ($(BR2_generic_arm),y)
-ifneq ($(BR2_arm610),y)
-ifneq ($(BR2_arm710),y)
        OPENSSL_TARGET_ARCH = armv4
 endif
-endif
-endif
-endif
 ifeq ($(ARCH),powerpc)
 # 4xx cores seem to have trouble with openssl's ASM optimizations
 ifeq ($(BR2_powerpc_401)$(BR2_powerpc_403)$(BR2_powerpc_405)$(BR2_powerpc_405fp)$(BR2_powerpc_440)$(BR2_powerpc_440fp),)