toolchain: add linaro 2012.03 external ARM toolchain
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 29 Mar 2012 22:22:47 +0000 (00:22 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 29 Mar 2012 22:22:47 +0000 (00:22 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 014bfc58361ce77150e276e65abb22ee42f8e4ac..991684fc06b54df7de2d1fa5e3107a8551372677 100644 (file)
@@ -3,6 +3,20 @@ if BR2_TOOLCHAIN_EXTERNAL
 choice
        prompt "Toolchain"
 
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_03
+       bool "Linaro 2012.03"
+       depends on BR2_arm
+       depends on BR2_cortex_a8 || BR2_cortex_a9
+       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+       select BR2_INSTALL_LIBSTDCPP
+       help
+         Linaro toolchain for the ARM architecture. It uses Linaro
+         GCC 2012.03 (based on gcc 4.6), Linaro GDB 2012.03, eglibc
+         2.13. It generates code that runs on all Cortex-A profile
+         devices, but tuned for the Cortex-A9. The code generated is
+         Thumb 2, with the softfp calling convention, and uses the
+         VFPv3-D16 FPU instructions.
+
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_02
        bool "Linaro 2012.02"
        depends on BR2_arm
@@ -484,6 +498,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        string
        default "arm-linux-gnueabi"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_01
        default "arm-linux-gnueabi"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_02
+       default "arm-linux-gnueabi"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_03
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2009Q3
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
index 51bce913b3a06f95ddb2d62bcb464a4bfbf9bb53..0a997a5931a5b91b6eab912e52708265e84daa21 100644 (file)
@@ -197,6 +197,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabi-2012.01-20120125_linux.ta
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_02),y)
 TOOLCHAIN_EXTERNAL_SITE=http://launchpad.net/linaro-toolchain-binaries/trunk/2012.02/+download/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabi-2012.02-20120222_linux.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_03),y)
+TOOLCHAIN_EXTERNAL_SITE=http://launchpad.net/linaro-toolchain-binaries/trunk/2012.03/+download/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabi-2012.03-20120326_linux.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2