package/dbus: disable systemd for host build
authorJohn Keeping <john@metanate.com>
Tue, 28 Jul 2020 10:45:19 +0000 (11:45 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 31 Jul 2020 07:10:16 +0000 (09:10 +0200)
This fixes an issue if host-dbus happens to be rebuilt after systemd, in
which case it autodetects systemd support but then ignored the prefix
when installing unit files.  That means that is tries to write to the
host system's /usr/lib/ which fails.

There is no reason to build and install systemd support in the host
build, so disable it explicitly.

Signed-off-by: John Keeping <john@metanate.com>
Tested-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dbus/dbus.mk

index 312c6ba1d890e4b39c55d83016c02a92b1a5a46b..3c6762568871cfc03350112ce8936f90a9254bf8 100644 (file)
@@ -107,6 +107,7 @@ HOST_DBUS_CONF_OPTS = \
        --disable-selinux \
        --disable-xml-docs \
        --disable-doxygen-docs \
+       --disable-systemd \
        --without-x \
        --with-xml=expat