pulseaudio: fix build with orc
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 12 May 2013 10:05:22 +0000 (10:05 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 May 2013 20:10:28 +0000 (22:10 +0200)
The configure script gets orcc from pkg-config, which sets it to /usr/bin/orcc
instead of $(HOST_DIR)/usr/bin/orcc. So set the path explicitly instead of
relying on pkg-config.

While we're at it, also add an explicit enable/disable to configure.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/pulseaudio/pulseaudio.mk

index aa67592d29e3abd35e3d933aa25eb997c37e1403..b39d99e182aaba327b958b1d7823095ab12970c1 100644 (file)
@@ -28,7 +28,6 @@ PULSEAUDIO_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_UDEV),udev) \
        $(if $(BR2_PACKAGE_OPENSSL),openssl) \
        $(if $(BR2_PACKAGE_FFTW),fftw) \
-       $(if $(BR2_PACKAGE_ORC),orc) \
        $(if $(BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING),webrtc-audio-processing) \
        $(if $(BR2_PACKAGE_SYSTEMD),systemd)
 
@@ -38,6 +37,14 @@ PULSEAUDIO_DEPENDENCIES = \
 PULSEAUDIO_AUTORECONF = YES
 PULSEAUDIO_DEPENDENCIES += libglib2
 
+ifeq ($(BR2_PACKAGE_ORC),y)
+PULSEAUDIO_DEPENDENCIES += orc
+PULSEAUDIO_CONF_ENV += ORCC=$(HOST_DIR)/usr/bin/orcc
+PULSEAUDIO_CONF_OPT += --enable-orc
+else
+PULSEAUDIO_CONF_OPT += --disable-orc
+endif
+
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 # The optional webrtc echo canceller is written in C++, causing auto* to want
 # to link module-echo-cancel.so with CXX even if webrtc ISN'T used.