aumix package
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jun 2007 10:07:16 +0000 (10:07 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 13 Jun 2007 10:07:16 +0000 (10:07 -0000)
package/Config.in
package/aumix/Config.in [new file with mode: 0644]
package/aumix/aumix.mk [new file with mode: 0644]

index ced6023d9349b8da31f55729b4e48d88b4aec8bd..50cfc4e863e6073dd77a175e6e06a86b3da5e86b 100644 (file)
@@ -240,6 +240,7 @@ menuconfig BR2_AUDIO_SUPPORT
 
 if BR2_AUDIO_SUPPORT
 source "package/asterisk/Config.in"
+source "package/aumix/Config.in"
 source "package/libid3tag/Config.in"
 source "package/libmad/Config.in"
 source "package/libsndfile/Config.in"
diff --git a/package/aumix/Config.in b/package/aumix/Config.in
new file mode 100644 (file)
index 0000000..2d5cdb3
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_AUMIX
+       bool "aumix"
+       default n
+       select BR2_PACKAGE_NCURSES
+       help
+         aumix is a small, easy-to-use program to control the mixer
+         of your sound card. It runs in text mode using the ncurses
+         library, or from the command line (non-interactively).
+         It can read default settings from a file, and it can also
+         automatically save and restore the mixer settings at shutdown
+         and boot.
+
+         http://jpj.net/~trevor/aumix.html
diff --git a/package/aumix/aumix.mk b/package/aumix/aumix.mk
new file mode 100644 (file)
index 0000000..4404867
--- /dev/null
@@ -0,0 +1,65 @@
+#############################################################
+#
+# aumix
+#
+#############################################################
+
+AUMIX_VERSION=2.8
+AUMIX_SOURCE=aumix-$(AUMIX_VERSION).tar.bz2
+AUMIX_SITE=http://jpj.net/~trevor/aumix
+AUMIX_DIR=$(BUILD_DIR)/aumix-$(AUMIX_VERSION)
+AUMIX_CAT:=$(BZCAT)
+
+$(DL_DIR)/$(AUMIX_SOURCE):
+       $(WGET) -P $(DL_DIR) $(AUMIX_SITE)/$(AUMIX_SOURCE)
+
+$(AUMIX_DIR)/.unpacked: $(DL_DIR)/$(AUMIX_SOURCE)
+       $(AUMIX_CAT) $(DL_DIR)/$(AUMIX_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(AUMIX_DIR)/.unpacked
+
+$(AUMIX_DIR)/.configured: $(AUMIX_DIR)/.unpacked
+       (cd $(AUMIX_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --sysconfdir=/etc \
+               --libdir=$(STAGING_DIR)/lib \
+               --includedir=$(STAGING_DIR)/include \
+               --without-gtk \
+               --without-gtk1 \
+               --without-alsa \
+               --without-gpm \
+               --without-sysmouse \
+               $(DISABLE_NLS) \
+       );
+       touch $(AUMIX_DIR)/.configured
+
+$(AUMIX_DIR)/src/aumix: $(AUMIX_DIR)/.configured
+       $(MAKE) CC=$(TARGET_CC) -C $(AUMIX_DIR)
+
+$(AUMIX_DIR)/.installed: $(AUMIX_DIR)/src/aumix
+       $(MAKE) -C $(AUMIX_DIR) DESTDIR=$(TARGET_DIR) install
+       touch $(AUMIX_DIR)/.installed
+
+aumix: uclibc ncurses $(AUMIX_DIR)/.installed
+
+aumix-source: $(DL_DIR)/$(AUMIX_SOURCE)
+
+aumix-clean:
+       -$(MAKE) -C $(AUMIX_DIR) clean
+
+aumix-dirclean:
+       rm -rf $(AUMIX_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_AUMIX)),y)
+TARGETS+=aumix
+endif