tn5250: fix openssl dir
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 10 Sep 2014 11:51:36 +0000 (08:51 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 13 Sep 2014 20:33:05 +0000 (22:33 +0200)
If openssl devfiles are installed in the host the automatic lookup might
find that and cause issues.
So be explicit on the directory to avoid a search and patch the
directory logic since it's got a bug. Fixes:
http://autobuild.buildroot.net/results/5dd/5ddc8636d6555851f692c0c21f583df235340b19/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tn5250/tn5250-01-ssldir.patch [new file with mode: 0644]
package/tn5250/tn5250.mk

diff --git a/package/tn5250/tn5250-01-ssldir.patch b/package/tn5250/tn5250-01-ssldir.patch
new file mode 100644 (file)
index 0000000..6fc78de
--- /dev/null
@@ -0,0 +1,17 @@
+Value is assigned to $with_ssl_dir but used from $with_ssl which is wrong.
+Fix configure since it's a one-liner and avoid an autoreconf.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura tn5250-0.17.4.orig/configure tn5250-0.17.4/configure
+--- tn5250-0.17.4.orig/configure       2014-09-10 08:33:15.689519554 -0300
++++ tn5250-0.17.4/configure    2014-09-10 08:33:47.428613117 -0300
+@@ -23258,7 +23258,7 @@
+ if test "${with_ssl_dir+set}" = set; then
+   withval=$with_ssl_dir;
+     if test "$with_ssl_dir" != "no"; then
+-         checksslinclude "$with_ssl"
++         checksslinclude "$with_ssl_dir"
+     else
+         for topdir in /usr/local /usr /usr/pkg /usr/lib /var/ssl /opt; do
+             for subdir in $topdir $topdir/openssl $topdir/ssl; do
index 2c4c2ad0baf0a7487d48f5fe8bd495e7d1551194..33f7c0c765fa5c4458f2649650efe4d005739404 100644 (file)
@@ -12,7 +12,7 @@ TN5250_LICENSE = LGPLv2.1+
 TN5250_LICENSE_FILES = COPYING
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
-       TN5250_CONF_OPT += --with-ssl
+       TN5250_CONF_OPT += --with-ssl-dir=$(STAGING_DIR)/usr
        TN5250_DEPENDENCIES += openssl
 else
        TN5250_CONF_OPT += --without-ssl