boot/barebox: kconfig needs the toolchain
authorJules Maselbas <jmaselbas@kalray.eu>
Tue, 8 Dec 2020 10:11:07 +0000 (11:11 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 29 Dec 2020 22:53:43 +0000 (23:53 +0100)
In barebox v2020.09.0, kconfig has been updated to a newer version
based on Linux 5.9-rc2.  As in linux, kconfig can call the compiler
to test its capabilities.

We have no way to know if a custom version would require it or not,
so we just unconditionally depend on the toolchain

Signed-off-by: Jules Maselbas <jmaselbas@kalray.eu>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
boot/barebox/barebox.mk

index 9d62037e7a4f853ff2d5efb039c75e4d570ae48d..77550aaed6df97af63073bd6c272f1292ef49ae4 100644 (file)
@@ -138,6 +138,11 @@ define $(1)_INSTALL_IMAGES_CMDS
        $$($(1)_INSTALL_CUSTOM_ENV)
 endef
 
+# Starting with barebox v2020.09.0, the kconfig used calls the
+# cross-compiler to check its capabilities. So we need the
+# toolchain before we can call the configurators.
+$(1)_KCONFIG_DEPENDENCIES += toolchain
+
 ifeq ($$(BR2_TARGET_$(1)_BAREBOXENV),y)
 define $(1)_INSTALL_TARGET_CMDS
        cp $$(@D)/scripts/bareboxenv-target $$(TARGET_DIR)/usr/bin/bareboxenv