package/python-pyzmq: enable draft APIs when supported by ZeroMQ
authorLionel Flandrin <lionel@svkt.org>
Tue, 5 Feb 2019 10:28:14 +0000 (11:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 16:19:53 +0000 (17:19 +0100)
This doesn't introduce a new config flag, instead it just automatically enables
draft support if it's configured in the zeromq package itself.

Signed-off-by: Lionel Flandrin <lionel@svkt.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-pyzmq/python-pyzmq.mk

index 1f7cb5d6136e4f81bc45696250fac2001495aa56..b977cca927f1fce552a597338a01641b991ed3fe 100644 (file)
@@ -22,4 +22,8 @@ endef
 
 PYTHON_PYZMQ_POST_PATCH_HOOKS += PYTHON_PYZMQ_PATCH_ZEROMQ_VERSION
 
+ifeq ($(BR2_PACKAGE_ZEROMQ_DRAFTS),y)
+PYTHON_PYZMQ_BUILD_OPTS += --enable-drafts
+endif
+
 $(eval $(python-package))