package/ruby: drop useless SuperH CFLAGS tweaks
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 30 Sep 2020 20:41:05 +0000 (22:41 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 30 Sep 2020 21:01:33 +0000 (23:01 +0200)
We dropped the CodeBench 2012.09 toolchain for SuperH a long time,
and with recent toolchains, Ruby at -Os builds perfectly fine, so
there's no reason to keep this work-around.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[yann.morin.1998@free.fr: slight rewording in the commit log]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/ruby/ruby.mk

index 6f8cb319cb95c84bef4b2962ad2785cfa6083297..d138aaaa1a5475d7cc18ee4d6de3edf1d76d187d 100644 (file)
@@ -20,15 +20,6 @@ HOST_RUBY_CONF_OPTS = \
 RUBY_LICENSE = Ruby or BSD-2-Clause, BSD-3-Clause, others
 RUBY_LICENSE_FILES = LEGAL COPYING BSDL
 
-RUBY_CFLAGS = $(TARGET_CFLAGS)
-# With some SuperH toolchains (like Sourcery CodeBench 2012.09), ruby fails to
-# build with 'pcrel too far'. This seems to be caused by the -Os option we pass
-# by default. To fix the problem, use standard -O2 optimization instead.
-ifeq ($(BR2_sh),y)
-RUBY_CFLAGS += -O2
-endif
-RUBY_CONF_ENV = CFLAGS="$(RUBY_CFLAGS)"
-
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 # On uClibc, finite, isinf and isnan are not directly implemented as
 # functions.  Instead math.h #define's these to __finite, __isinf and