freetype: host-freetype-patch requires host-automake
authorFabio Porcedda <fabio.porcedda@gmail.com>
Fri, 27 Feb 2015 09:19:22 +0000 (10:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 28 Feb 2015 09:10:21 +0000 (10:10 +0100)
The "make host-freetype-patch" fails because using the autogen.sh script
doesn't find the autoconf tool. The problem was already fixed for
"make freetype-patch" adding the "host-automake" as a prerequisite to
freetype-patch, so fix it by adding "host-automake" as a prerequisite to
"host-freetype-patch" too.

Fix build failure:
running `autoconf --force'
./autogen.sh: line 15: autoconf: command not found
error while running `autoconf --force'
package/pkg-generic.mk:146: recipe for target 'buildroot/output/build/host-freetype-2.5.5/.stamp_patched' failed

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freetype/freetype.mk

index 0de5ce3dedd538974801c70d5a18a5ecef7f4903..56274cb436c8d1751b1f97d5647982bf0a38bf68 100644 (file)
@@ -98,6 +98,7 @@ HOST_FREETYPE_POST_INSTALL_HOOKS += HOST_FREETYPE_FIX_FREETYPE_INCLUDE
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))
 
-# freetype-patch uses autogen.sh so add it as a order-only-prerequisite
-# because it is a phony target.
-$(FREETYPE_TARGET_PATCH): | host-automake
+# freetype-patch and host-freetype-patch use autogen.sh so add
+# host-automake as a order-only-prerequisite because it is a phony
+# target.
+$(FREETYPE_TARGET_PATCH) $(HOST_FREETYPE_TARGET_PATCH): | host-automake