target-finalize: fix calling ldconfig
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 17 Apr 2015 16:10:33 +0000 (18:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 18 Apr 2015 13:56:41 +0000 (15:56 +0200)
On some systems (e.g. Fedora 20), the build breaks when parsing include
directives in our /etc/ld.so.conf, with error messages as thus:

    /sbin/ldconfig: need absolute file name for configuration file
    when using -r

So, enforce the path to the ld.so.conf file to point to our own, in the
target/ directory.

Reported-by: Al West <al.west@v-nova.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 6a28b2824da124d1bdcc217f46b271992ecb709e..d1d6ab33e647a30ae0e51fa617e737b1b5601726 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -583,9 +583,11 @@ endif
        mkdir -p $(TARGET_DIR)/var/cache/ldconfig
        if [ -x "$(TARGET_CROSS)ldconfig" ]; \
        then \
-               $(TARGET_CROSS)ldconfig -r $(TARGET_DIR); \
+               $(TARGET_CROSS)ldconfig -r $(TARGET_DIR) \
+                                       -f $(TARGET_DIR)/etc/ld.so.conf; \
        else \
-               /sbin/ldconfig -r $(TARGET_DIR); \
+               /sbin/ldconfig -r $(TARGET_DIR) \
+                              -f $(TARGET_DIR)/etc/ld.so.conf; \
        fi
        ( \
                echo "NAME=Buildroot"; \