wpa_supplicant: install systemd service files
authorMike Williams <mike@mikebwilliams.com>
Fri, 20 Mar 2015 19:14:15 +0000 (15:14 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Mar 2015 19:43:11 +0000 (20:43 +0100)
Unlike other systemd services, these are not enabled by default, as the
most likely configuration is that they will be managed by something like
NetworkManager.

Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wpa_supplicant/wpa_supplicant.mk

index 5a81a9158177dfb3f1c298774fc0cf3d557a5cf1..4b2ec164d7915df7e9fab0016aad724957dade40 100644 (file)
@@ -165,4 +165,15 @@ define WPA_SUPPLICANT_INSTALL_TARGET_CMDS
        $(WPA_SUPPLICANT_INSTALL_DBUS)
 endef
 
+define WPA_SUPPLICANT_INSTALL_INIT_SYSTEMD
+       $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant.service
+       $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant@.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant@.service
+       $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant-nl80211@.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant-nl80211@.service
+       $(INSTALL) -m 0644 -D $(@D)/$(WPA_SUPPLICANT_SUBDIR)/systemd/wpa_supplicant-wired@.service \
+               $(TARGET_DIR)/usr/lib/systemd/system/wpa_supplicant-wired@.service
+endef
+
 $(eval $(generic-package))