package/weston: Add demo clients install option
authorSergi Granell <xerpi.g.12@gmail.com>
Fri, 15 Jul 2016 13:14:09 +0000 (15:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 Jul 2016 17:37:04 +0000 (19:37 +0200)
Signed-off-by: Sergi Granell <xerpi.g.12@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/Config.in
package/weston/weston.mk

index 0812279cf7e65520a67a94ba5a57924768662be5..c1eb7dadb22d529678e03e4b81ceda7178f58654 100644 (file)
@@ -104,4 +104,9 @@ config BR2_PACKAGE_WESTON_XWAYLAND
 comment "XWayland support needs libepoxy and X.org enabled"
        depends on !BR2_PACKAGE_XORG7 || !BR2_PACKAGE_LIBEPOXY
 
+config BR2_PACKAGE_WESTON_DEMO_CLIENTS
+       bool "demo clients"
+       help
+         This enables the installation of Weston's demo clients.
+
 endif
index dfcb9acbf59d88e71bfe785410b93c3f28c11c4d..31c9281bb8d372892d6d86368dd8d427075d7663 100644 (file)
@@ -142,4 +142,10 @@ else
 WESTON_CONF_OPTS += --disable-junit-xml
 endif
 
+ifeq ($(BR2_PACKAGE_WESTON_DEMO_CLIENTS),y)
+WESTON_CONF_OPTS += --enable-demo-clients-install
+else
+WESTON_CONF_OPTS += --disable-demo-clients-install
+endif
+
 $(eval $(autotools-package))