rpcbind: install init script unconditionally
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:45 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 23:24:39 +0000 (00:24 +0100)
As discussed, users should use a rootfs overlay or a post-build script
instead of a custom skeleton to override files installed by Buildroot,
so there is no point in having conditions when installing init scripts
or configuration files.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rpcbind/rpcbind.mk

index b7c2261030e37669091c3cbd35dd86d6d95f16ec..55de3fcc7d9a049f8a213ccfa77b8376bd1ad7ce 100644 (file)
@@ -17,9 +17,8 @@ RPCBIND_DEPENDENCIES += libtirpc
 RPCBIND_CONF_OPTS += --with-rpcuser=root
 
 define RPCBIND_INSTALL_INIT_SYSV
-       [ -f $(TARGET_DIR)/etc/init.d/S30rpcbind ] || \
-               $(INSTALL) -m 0755 -D package/rpcbind/S30rpcbind \
-                       $(TARGET_DIR)/etc/init.d/S30rpcbind
+       $(INSTALL) -m 0755 -D package/rpcbind/S30rpcbind \
+               $(TARGET_DIR)/etc/init.d/S30rpcbind
 endef
 
 $(eval $(autotools-package))