qt: remove PKG_CONFIG workaround
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:30 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:38:04 +0000 (14:38 +0200)
At least Qt 4.5.2 is fixed in the meantime and honors PKG_CONFIG.
So the PATH workaround is no longer needed.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 09a027df243eb35a2f0fe1a0a001b9b012c2bf64..77e7f1a3bbf5b80297551213f440d20061a64daf 100644 (file)
@@ -444,16 +444,12 @@ endif
        $(call QT_QMAKE_SET,LFLAGS,$(TARGET_LDFLAGS))
        -[ -f $(QT_QCONFIG_FILE) ] && cp $(QT_QCONFIG_FILE) \
                $(QT_TARGET_DIR)/$(QT_QCONFIG_FILE_LOCATION)
-# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.
-# PKG_CONFIG_SYSROOT is only used to avoid a warning from Qt's configure system
-# when cross compiling, Qt 4.4.3 is wrong here.
 # Don't use TARGET_CONFIGURE_OPTS here, qmake would be compiled for the target
-# instead of the host then.
+# instead of the host then. So set PKG_CONFIG* manually.
        (cd $(QT_TARGET_DIR); \
-               PATH=$(TARGET_PATH) \
                PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
+               PKG_CONFIG="$(PKG_CONFIG_HOST_BINARY)" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig:$(PKG_CONFIG_PATH)" \
-               PKG_CONFIG_SYSROOT="$(STAGING_DIR)" \
                ./configure \
                $(if $(VERBOSE),-verbose,-silent) \
                -force-pkg-config \