Support .dotfiles in / being copied to the TARGET
authorTilman Keskinöz <arved@arved.at>
Mon, 25 Mar 2013 04:48:11 +0000 (04:48 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Mar 2013 22:38:26 +0000 (23:38 +0100)
An example is .init_enable_core, to enable coredumps in busybox

Signed-off-by: Tilman Keskinöz <arved@arved.at>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index f1c98aa9335ae70768b05131f202169e5db423cc..62311ede36ee9d2cfe5dc59b985f8f6cb278a90c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -431,7 +431,7 @@ $(BUILD_DIR)/.root:
        mkdir -p $(TARGET_DIR)
        if ! [ -d "$(TARGET_DIR)/bin" ]; then \
                if [ -d "$(TARGET_SKELETON)" ]; then \
-                       cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
+                       rsync -au $(TARGET_SKELETON)/ $(TARGET_DIR)/; \
                fi; \
        fi
        cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)