tmux: bump to version 2.2
authorRicardo Martincoski <ricardo.martincoski@gmail.com>
Mon, 20 Jun 2016 04:46:11 +0000 (01:46 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 1 Jul 2016 09:12:49 +0000 (11:12 +0200)
- remove patch already upstream 0001-remove-use-of-sys-cdefs.h.patch
https://github.com/tmux/tmux/commit/7b085136a7291cbcdfcc53182fbd13aaca70306e
- add new dependency on BR2_USE_WCHAR (version 2.2 uses mbtowc())
- add new dependency on locale support
- add note to help text about the need of a working UTF-8 locale
- also rewrap help text to 72 characters

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tmux/0001-remove-use-of-sys-cdefs.h.patch [deleted file]
package/tmux/Config.in
package/tmux/tmux.hash
package/tmux/tmux.mk

diff --git a/package/tmux/0001-remove-use-of-sys-cdefs.h.patch b/package/tmux/0001-remove-use-of-sys-cdefs.h.patch
deleted file mode 100644 (file)
index 929953f..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-From 29e4794ca396a8db8a468ec74559922d2af5a987 Mon Sep 17 00:00:00 2001
-From: Nicholas Marriott <nicholas.marriott@gmail.com>
-Date: Tue, 24 Nov 2015 18:46:50 +0000
-Subject: [PATCH] -sys/queue.h in proc.c, and nuke the unnecessary C++ header
- guards stuff and sys/cdefs.h in vis.h (it causes problems on some platforms).
- Reported by someone on GitHub, issue 212.
-
----
-Backported from master upstream to fix musl build
-https://github.com/tmux/tmux/commit/7b085136a7291cbcdfcc53182fbd13aaca70306e
-
-proc.c does not exist on version 2.1
-
-Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
----
- compat/vis.h | 5 -----
- 1 file changed, 5 deletions(-)
-
-diff --git a/compat/vis.h b/compat/vis.h
-index 6795139..9f12d23 100644
---- a/compat/vis.h
-+++ b/compat/vis.h
-@@ -73,9 +73,6 @@
-  */
- #define       UNVIS_END       1       /* no more characters */
--#include <sys/cdefs.h>
--
--__BEGIN_DECLS
- char  *vis(char *, int, int, int);
- int   strvis(char *, const char *, int);
- int   stravis(char **, const char *, int);
-@@ -85,6 +82,4 @@ int  strunvis(char *, const char *);
- int   unvis(char *, char, int *, int);
- ssize_t strnunvis(char *, const char *, size_t);
--__END_DECLS
--
- #endif /* !_VIS_H_ */
--- 
-1.9.1
-
index 61719e486682fe59c4cafd226d6242f24aa43430..756f38a08826e8139c8a5440bf21165686c5a4b2 100644 (file)
@@ -1,10 +1,19 @@
 config BR2_PACKAGE_TMUX
        bool "tmux"
        depends on BR2_USE_MMU # fork()
+       depends on BR2_USE_WCHAR # mbtowc()
+       depends on BR2_ENABLE_LOCALE # runtime
        select BR2_PACKAGE_LIBEVENT
        select BR2_PACKAGE_NCURSES
        help
-         tmux is a terminal multiplexer, it enables a number of terminals
-         (or windows) to be accessed and controlled from a single terminal.
+         tmux is a terminal multiplexer, it enables a number of
+         terminals (or windows) to be accessed and controlled from a
+         single terminal.
+
+         NOTE: tmux needs a working UTF-8 locale (BR2_GENERATE_LOCALE)
 
          https://tmux.github.io/
+
+comment "tmux needs a toolchain w/ wchar, locale"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_ENABLE_LOCALE
index e732aa24bb2c2d908ef2b28d84c674a1ae376a68..f3cbe74455f1b8c0be8610c9a6ea2845fe06624e 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed:
-sha256  31564e7bf4bcef2defb3cb34b9e596bd43a3937cad9e5438701a81a5a9af6176  tmux-2.1.tar.gz
+sha256  bc28541b64f99929fe8e3ae7a02291263f3c97730781201824c0f05d7c8e19e4  tmux-2.2.tar.gz
index 40f1a13898324a51cf8e95395e4f0364b0386384..1e1b2b7ce76f31c04bde51887ae5813fd4bb61d8 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TMUX_VERSION = 2.1
+TMUX_VERSION = 2.2
 TMUX_SITE = https://github.com/tmux/tmux/releases/download/$(TMUX_VERSION)
 TMUX_LICENSE = ISC
 TMUX_LICENSE_FILES = README